Asus Tinker Board – First Impressions


My Asus Tinker Board arrived yesterday from CPC, and I did a quick tweet with unboxing photos. Having taken it for a quick test drive here are my first impressions based on running up their Debian image[1] (I’ve not had the time to try Kodi yet).

Tinker Board

Tinker Board before mounting heatsink on SOC

Reassuringly expensive

The Tinker Board is £55, which is a good chunk more than a RPi3 at £32 – that’s quite a premium for a bit more CPU performance and RAM. I like the annotated PCB, and it’s also good to have a clicky MicroSD slot (like the RPi2 had rather than the cheaper feeling ones on the RPi3).


It boots straight into a GUI desktop. Chromium is there, and seems fast enough to be used as a desktop machine (if you can live with a 1080p screen). I guess if I can get by with 2GB RAM on my Chromebook then I can get by with 2GB RAM on this.

I’ve not yet figured out which window manager it’s using (likely whatever Debian default is).


Connecting to WiFi from the desktop was easy – click the button, select the network, enter password.

Getting the gigabit wired network working was not so easy/obvious (for something that should ‘just work’). I could see from my switch that the network was up (and connected at GigE), but the interface didn’t connect and pull a DHCP address and the usual command line invocations like ‘ifdown eth0 && ifup eth0’ weren’t working. Eventually it seems that I clicked something in the desktop UI that provoked action, and at least once it was up it stayed up across power cycles.

The OS image

It’s pretty obvious that somebody at Asus cloned an OS from their working Tinker Board, I can even see their command history for the bits and bobs that they installed by hand. This is not how professionals build and release an image, and I’m guessing my network issues might be related to the hardware MACs on my Tinker Board being different from the ones on the one the snapshot came from. At least the base is relatively stock Debian Jesse.


When the board boots into a desktop it’s with the user ‘linaro’, which happens to have a password ‘linaro’; that user is part of the sudo group, and so can jump straight into doing stuff as root. So we have a hard coded username and password for a user who can get to root.

SSH is listening by default, making it possible to log in remotely (with the hard coded username and password).

The Raspberry Pi foundation did a better job with this stuff, and Asus clearly haven’t learned those lessons, which is a shame.

How could this be better?

If the supplied image booted into a late stage customisation script with the following few options that would be much better:

  • Desktop or CLI?
  • Username and password?
  • SSH (and other exposed services) on or off?

If it was possible to provide a cloud-init like way of supplying customisation to do that without human touch then even better.

It runs hot

I found the included SOC heatsink after I’d done the unboxing photos, and popped it on. It gets pretty hot, so my guess is that it’s needed (or the SOC would be frying). The quick start guide specifies a 2A USB power supply (so that’s 10W). I tried to measure current draw with my PLX Legion Meter, but I couldn’t get it to boot as it seems to try to draw more current than the meter can supply.

That’s it for now

I’ve not had the chance to do anything meaningful with the board yet (let alone build a project around it). Next up I’ll try the Kodi build and see if the x.265 hardware decoding can be used there.


[1] The quick start guide doesn’t have download links (I’m guessing they weren’t ready at the time of printing), and they’re not that easy to find with search. Here’s the download site (though it wasn’t working at the time of writing – sigh). Updated 18 Feb 2017 – There’s a new download site, but it doesn’t seem to have a Kodi image.

4 Responses to “Asus Tinker Board – First Impressions”


    Just got my tinkerboard – got the KODI OS downloaded and installed – ethernet off by default – no ssh by default- had to come here to find the user password – apt won’t update the system, and all USB keyboards are very glitchy. Not a great start.

    • 2 Steve Williams

      I’ve got a mixture of 5v 2a, 2.1a and 3a adapters and my device is constantly going off when doing apt-get update (with next to nothing connected). When I manage to get the keyboard to work, I can expect for it to stop responding and not work (until a reboot) after about 30 seconds.

      This has got to be the worst SBC I’ve ever bought. All I wanted to do was get LXC working and get a few containers on it, but it’s simply not worth the effort. I wish I’d just bought the Odroid C2 now.

  2. Just tried putting an order for two units.

    As it seems CPC/ Farnell “has stopped the sale of the tinker board.”

    “This is due to an error on the data, Some customers have been having some issues”

    • I’m just seeing a message that they’re out of stock – ‘7 will be available for delivery on Feb 14, 2017. Contact me when back in stock. Awaiting Delivery (Available for backorder to lead times shown)’. CPC only had about 35 of them when I placed my order, so I’m not surprised that they’re gone. 7 being available in a couple of weeks suggests that there is some supply, but that it’s pretty thin. This is all too typical for dev board manufacturers – they haven’t been able to balance demand and supply (as we’ve seen with BeagleBone Black and Raspberry Pi Zero).

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: